目录

◆ 第一章　三分損益律的初步探討
◆ 第二章　三分損益律的進一步探討
◆ 第三章　求解三分損益係數值
◆ 第四章　重訂鋼琴音譜


第一章　三分損益律的初步探討

    三分損益律不是獨立的音律法，只是黃鐘十二律的計算方法。古人用的黃鐘十二律玄奧複雜，而今天又未能見“三分損益法”的道理所在。筆者猜測，“三分損益法”的“三分益一和三分損一”只是實用之粗率。在使用中還需用他法調整。而這一點，筆者無從考究，只好另尋他法。

    （一）三分損益係數

    假設黃鐘律長為Ｌ０，他律依建序為Ｌｘ，Ｘ從一到十二。Ｌ１２代表高音鄰組黃鐘之律長。又設三分損益係數為Ｋ，我們可以做如下推算：

    Ｌ０＝Ｌ０

    根據律呂相生的三分損益法，可以計算其他律長：

    Ｌ７＝Ｌ０－ＫＬ０＝（１－Ｋ）Ｌ０

    Ｌ２＝Ｌ７＋ＫＬ７＝（１+Ｋ）（１－Ｋ）Ｌ０

    Ｌ９＝Ｌ２－ＫＬ２＝（１+Ｋ）（１－Ｋ）２Ｌ０

    Ｌ４＝Ｌ９＋ＫＬ９＝（１+Ｋ）２（１－Ｋ）２Ｌ０

    Ｌ１１＝Ｌ４－ＫＬ４＝（１+Ｋ）２（１－Ｋ）３Ｌ０

    Ｌ６＝Ｌ１１＋ＫＬ１１＝（１+Ｋ）３（１－Ｋ）３Ｌ０

    Ｌ１＝Ｌ６＋ＫＬ６＝（１+Ｋ）４（１－Ｋ）３Ｌ０

    Ｌ８＝Ｌ１－ＫＬ１＝（１+Ｋ）４（１－Ｋ）４Ｌ０

    Ｌ３＝Ｌ８＋ＫＬ８＝（１+Ｋ）５（１－Ｋ）４Ｌ０

    Ｌ１０＝Ｌ３－ＫＬ３＝（１+Ｋ）５（１－Ｋ）５Ｌ０

    Ｌ５＝Ｌ１０＋ＫＬ１０＝（１+Ｋ）６（１－Ｋ）５Ｌ０

    Ｌ１２＝Ｌ５－ＫＬ５＝（１+Ｋ）６（１－Ｋ）６Ｌ０……（１）

    Ｌ０＝Ｌ５＋ＫＬ５＝（１+Ｋ）７（１－Ｋ）５Ｌ０………（２）

    由（２）式得：

    （１+Ｋ）７（１－Ｋ）５＝１……………………………（３）

    由（３）式我們可以解出Ｋ值，這就是所要找出的三分損益係數。同時根據（３）式我們知道了：

    Ｋ≠１／３

    我們把（３）稱為“三分損益係數方程”

    設（１+Ｋ）７（１－Ｋ）５＝Ｍ……………………（４）

    我們稱Ｍ為“黃鐘回歸率”。根據Ｋ值，可以計算出“黃鐘回歸率”。

    由（１）式我們可以看出，（１+Ｋ）６（１－Ｋ）６就是高音鄰組黃鐘之律長Ｌ１２與本組黃鐘之律長Ｌ０的比值。我們名之為組律比。設組律比為Ｑ，則：

    （１+Ｋ）６（１－Ｋ）６＝Ｑ……………………………（５）

    我們稱（５）式為組比率方程。由（４）（５）

    式我們可以看出組律比

    Ｑ≠１/２

    由此觀之，朱載堉的十二平均律和傳統的十二律有很大差別：前者組律比＝１/２，而後者的組律比≠１/２！

    （二）律數比

    計算得：

    呂律比（Ｌ１/Ｌ０、Ｌ３／Ｌ２、Ｌ５／Ｌ４）＝

    律呂比（Ｌ８／Ｌ７、Ｌ１０／Ｌ９、Ｌ１２／Ｌ１１）

    ＝（１+Ｋ）４（１－Ｋ）３…………………（６）

    律呂比（Ｌ２／Ｌ１、Ｌ４／Ｌ３、Ｌ６／Ｌ５）＝

    呂律比（Ｌ７／Ｌ６、Ｌ９／Ｌ８、Ｌ１１／Ｌ１０）

    ＝１／（（１+Ｋ）３（１－Ｋ）２）…………（７）

    律間比（Ｌ２／Ｌ０、Ｌ４／Ｌ２、Ｌ６／Ｌ４、Ｌ８／Ｌ６、

    Ｌ１０／Ｌ８、Ｌ１２／Ｌ１０）

    ＝（１+Ｋ）（１－Ｋ）…………………………………（８）

    呂間比（Ｌ３/Ｌ１、Ｌ５/Ｌ３、Ｌ９/Ｌ７、Ｌ１１/Ｌ９）

    ＝（１+Ｋ）（１－Ｋ）……………………………（９）

    特殊的呂間比Ｌ７/Ｌ５＝

    １/（（１+Ｋ）６（１－Ｋ）４）…………（１０）

    設

    （１+Ｋ）（１－Ｋ）＝Ｎ…………………………（１１）

    我們稱Ｎ為“律間公比”或“呂間公比”。注意，不是“律呂公比”。

    Ｎ１/２＝（（１+Ｋ）（１－Ｋ））１/２

    我們稱（（１+Ｋ）（１－Ｋ））１/２為“律呂公比”。

    比較林鐘仲呂之間的距離Ｌ７/Ｌ５與太簇黃鐘之間的距離Ｌ３/Ｌ１的大小，則有：

    Ｌ７/Ｌ５*（平衡係數）＝Ｌ３/Ｌ１

    １/（（１+Ｋ）６（１－Ｋ）４）*（平衡係數）＝（１+Ｋ）（１－Ｋ）

    平衡係數＝（１+Ｋ）７（１－Ｋ）５

    代入（３），得

    平衡係數＝１

    故有

    Ｌ７/Ｌ５＝Ｌ３/Ｌ１

    所以這個特殊的呂間比Ｌ７/Ｌ５與其他呂間比比值相同。

    由於

    Ｌ７/Ｌ５＝Ｌ３/Ｌ１＝Ｌ１２／Ｌ１０）

    則有Ｌ７/Ｌ５＝Ｌ１２／Ｌ１０）

    代入運算式為：

    １/（（１+Ｋ）６（１－Ｋ）４）

    ＝（１+Ｋ）（１－Ｋ）……………………………（１２）

    我們稱之為：子午同心方程

    把Ｌ７/Ｌ５＝Ｌ３/Ｌ１

    代換為

    Ｌ７/Ｌ６*Ｌ６/Ｌ５＝Ｌ３/Ｌ２*Ｌ２/Ｌ１

    （１／（（１+Ｋ）３（１－Ｋ）２））*（１／（（１+Ｋ）３（１－Ｋ）２））

    ＝（（１+Ｋ）４（１－Ｋ）３）*（１／（（１+Ｋ）３（１－Ｋ）２））

    簡化算式，有

    １／（（１+Ｋ）３（１－Ｋ）２）

    ＝（１+Ｋ）４（１－Ｋ）３…………………………（１３）

    再根據（６）（７）兩個等式，可見：

    十二律間律數比完全相等。

    我們稱（１２）式為“律呂有別方程”。只有在Ｋ值高度精確時，方程才能成立。不同的律呂間比運算式才能相等。其中

    １／（（１+Ｋ）３（１－Ｋ）２）

    和（１+Ｋ）４（１－Ｋ）３

    都稱為“律呂間比”

    （三）結論

    由上述計算分析，我們可以得出如下結論：

    【一】一般所說的三分損益推算法為粗率法，而實際古傳的三分損益係數不等於三分之一。即

    Ｋ≠１／３

    【二】古傳的黃鐘十二律的組律比不等於二分之一。即

    Ｑ≠１/２

    【三】古傳的黃鐘十二律也是平均律，完全可以實現遊宮轉調。


第二章　三分損益律的進一步探討

    考慮方程式（３）（４）（５）。

    根據方程式（１+Ｋ）７（１－Ｋ）５＝１我們知道Ｋ值為無理數。現在我們可以用漸進法來逼近他的值。

    設

    Ｑ＝２１８/３１２

    =０.４９３２７０１８４２７　　　　　　　　　則

    （１+Ｋ）６（１－Ｋ）６＝Ｑ＝２１８/３１２

    相鄰兩個律間，或相鄰兩個呂間的律數公比

    N=（１+Ｋ）（１－Ｋ）＝８/９

    由此可見，所謂“五度相生律”的律數比８/９也是粗率。“五度相生律”的“呂律公比”為：

    Ｎ１/２＝２３/２/３＝０.９４２８０９０４１５８２

    而朱載堉的十二平均律的“呂律公比”為：

    Ｎ１/２＝２－１/１２＝０.９４３８７４３１２６８１

    後者大於前者。

    進一步計算得:

    Ｋ＝１/３　　　　　　　　　　　　　　　則

    黃鐘回歸率

    Ｍ＝（１+Ｋ）７（１－Ｋ）５＝２１９/３１２

    ＝０.９８６５４０３６８５５

    設Ｑ＝１/２　　　　　　　　　　　　　　　則

    Ｋ＝（１－２－１/６）１/２

    ＝０．３３０３０４８３１７８

    Ｍ＝（１+Ｋ）７（１－Ｋ）５

    ＝０．９９３２１６６８６１３

    可見Ｑ值應大於１/２，而Ｋ值應小於１/３。即

    Ｑ＞１／２

    Ｋ＜１／３

    歸納如下：

    表一：設Ｑ值得到Ｋ和Ｍ測算值

    結論：

    【一】古傳的黃鐘十二律的組比率大於二分之一。

    【二】古傳的三分損益係數小於三分之一。

    【三】朱載堉的十二平均律的“呂律公比”大於“五度相生律”的“呂律公比”。因此，以中央Ｃ為中心點，在音高上，比“五度相生律”收斂。


第三章　求解三分損益係數值

    經驗算，我們得到Ｋ的近似值：

    Ｋ＝３－１－３－５和Ｋ＝３－１－２*３－５

    表二：設Ｋ值得到Ｑ和Ｍ測算值

    比較上述計算之Ｍ值，得:

    ３－１－２*３－５＜Ｋ＜３－１－３－５

    設Ｋ＝３－１－３－５（３/２）得：

    表三：設Ｋ值得到Ｑ和Ｍ測算值

    以此方法推算Ｋ的近似分數，繼續計算得:

    表四：設Ｋ值得到Ｑ和Ｍ測算值

    表四續

    表四續

    表四續

    結論：

    【一】計算出有效數字值：

    Ｋ＝0.32718348245781

    Ｑ＝0.5069506412905

    【二】繼續計算，可以得到更高精確度的Ｋ、Ｑ、Ｍ值。


第四章　重訂鋼琴音譜

    本重訂鋼琴音譜採用物理音譜序號，因為他的編號更規範。

    設中央Ｃ，Ｃ４的頻率為：

    ｆｃ４＝１（倍）

    ｆｃ４的具體頻率值可根據實際需要調整。

    設Ｃ４鍵“音厘”值為０，十二律組音厘值為１２００音厘，注意，這裏的“音厘”值與以往的音分值定義不同，大小也不同，則有：

    表五：本書密率九律組起始音律數頻率和音厘值

    （假設Ｃ４為黃鐘）

    其中：Ｑ＝0.5069506412905

    表六:　不同密率法頻率倍數比值和頻率倍數差值

    （假設Ｃ４為黃鐘）

    本表解釋了,為什麼按照朱載堉的平均律計算的頻率值表現在低音組音高過低,而在高音組音高又過高的問題。

    結論：

    用本書密率法計算的頻率值，比用朱載堉密率法計算的頻率值，以中央Ｃ為中心點，收斂。

    表七：不同密率法與本書密法音分差數

    （假設Ｃ４為黃鐘）

    根據定義，可計算出：

    音厘＝音分／（２Ｑ）

    ＝音分*０.９８６２８９３１３５４５７。

    本書密率法八度組音分值

    ＝１１８３.５４７１７６２５４９３５５音分

    五度相生律八度組音分值

    ＝１２００*１.００１９３７７３６９０１５音分

    ＝１２０２.３２５２８４２８１８９０６音分。

    表八：十二律律數頻率和音厘值（假設Ｃ４為黃鐘）

    其中：以Ｋ＝0.32718348245781的精確度值已經可以滿足調琴之用。［本文完於２０１５年５月８日於中國·吉林］